El Premio.tap

Software para o relacionado con el core ZX Spectrum / Software for or related to the ZX Spectrum core
javidoom
Mensajes: 51
Registrado: 19 Mar 2016, 12:11

El Premio.tap

Mensaje por javidoom » 23 Abr 2016, 18:46

Holas!

Lo mio con este juego no lo puedo solucionar... A ver si alguien de por aquí me encuentra qué pasa...

Explico:

Emulador: Zesarux última versión.
Juego: El premio (sacado el tap del WOS).
Síntoma: El teclado solo funciona la primera vez que arrancas el emulador.

Lo que hago, es cargar el emulador:

F5 - Machine Selection: ZX-Uno.
F5 - Smartload: El Premio.tap.
FUNCIONA! Con 5678 y 0.

Ok, por ahora bien. Pero si vuelves a cargarlo, ya no va se mueve la nave... no se puede jugar.
Vale, pues vuelves a seleccionar Machine Selection, ZX-Uno etc... y tampoco va!

Has de reiniciar el Zesaux para que vuelva a ir.

En Spectaculator no funciona... (Sólo kempston)...
En la FPGA Mist, tampoco va, ni con tap, ni con CSW.
En la FPGA V6Z80P tampoco va... Ni cargando la cinta original en el core sin ESXDOS y lo más sencillo posible!

Por ello mi manía de jugarlo y que no sea en un emulador! Qué le pasa a este juego que es tan pejiguero?? Alguna idea?

Gracias!
Vintagenarios powaaa!

Avatar de Usuario
chernandezba
Mensajes: 831
Registrado: 02 Oct 2015, 23:35

Re: El Premio.tap

Mensaje por chernandezba » 23 Abr 2016, 21:09

Raro raro... En principio cuando haces machine selection y seleccionas zxuno es lo mismo que al arrancar el emulador desde cero, y es casi lo mismo que hacer un hard reset..
No se me ocurre qué puede ser, y más raro aún es que haya emuladores que ni funcione.
Has probado en ZEsarUX pero probando con otra máquina? Spectrum 48 o 128?
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
chernandezba
Mensajes: 831
Registrado: 02 Oct 2015, 23:35

Re: El Premio.tap

Mensaje por chernandezba » 23 Abr 2016, 21:14

No he probado el tap pero por lo que veo en WOS este juego debes cargarlo en modo 48k, por tanto o bien seleccionas spectrum 48k en emulador, o si seleccionas zxuno, debes entrar en la bios de zxuno y arrancarlo en modo 48k
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
chernandezba
Mensajes: 831
Registrado: 02 Oct 2015, 23:35

Re: El Premio.tap

Mensaje por chernandezba » 23 Abr 2016, 21:15

El link para quien lo quiera probar, que en el índice de WOS aparece con su nombre en inglés y no es fácil encontrarlo:

http://www.worldofspectrum.org/infoseek ... id=0003885
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

javidoom
Mensajes: 51
Registrado: 19 Mar 2016, 12:11

Re: El Premio.tap

Mensaje por javidoom » 23 Abr 2016, 21:16

chernandezba escribió:Raro raro... En principio cuando haces machine selection y seleccionas zxuno es lo mismo que al arrancar el emulador desde cero, y es casi lo mismo que hacer un hard reset..
No se me ocurre qué puede ser, y más raro aún es que haya emuladores que ni funcione.
Has probado en ZEsarUX pero probando con otra máquina? Spectrum 48 o 128?
Hola

Sí, lo he probado, es más, nada más entrar en el emulador, lo cargas con SMART LOAD y va. Pero lo vuelves a cargar y ya deja de ir.
Cambias de máquina, y sigue sin ir...

Veo ahora tu modificación, y siempre lo cargo en 48K... Seleccionando la máquina en ZXuno antes de arrancarlo.
Vintagenarios powaaa!

Avatar de Usuario
chernandezba
Mensajes: 831
Registrado: 02 Oct 2015, 23:35

Re: El Premio.tap

Mensaje por chernandezba » 23 Abr 2016, 21:20

Muy extraño... Has probado en Fuse?

Lo único que se me ocurre es que el juego tenga algún tipo de fallo y no funcione según el valor de algún registro de la cpu... Algún registro que al iniciar el emulador tenga un valor fijo pero que cuando haces un reset ese registro tenga otro valor...
Pero vamos que me suena muy raro, ya te digo que al seleccionar máquina de nuevo es lo mismo que entrar de nuevo al emulador.
Yo no le daría muchas vueltas pero si aún así quieres saber que falla, deberás hacer debug del juego y ver porque no se mueve la nave
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
antoniovillena
Mensajes: 2611
Registrado: 27 Sep 2015, 20:41

Re: El Premio.tap

Mensaje por antoniovillena » 23 Abr 2016, 21:49

Es que en esa configuración tienes paginación 128k con ROM de 48k

Avatar de Usuario
chernandezba
Mensajes: 831
Registrado: 02 Oct 2015, 23:35

Re: El Premio.tap

Mensaje por chernandezba » 23 Abr 2016, 22:34

Que configuración?
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

javidoom
Mensajes: 51
Registrado: 19 Mar 2016, 12:11

Re: El Premio.tap

Mensaje por javidoom » 23 Abr 2016, 22:52

Acabo de montar la V6Z80p y no hay tu tía...
Ni con el core anterior de Alessandro Dorigatti, ni con el nuevo para pendulum. Con ambos hace lo mismo, el juego arranca pero no mueves las nave. En 48k y en 128k, con y sin ESXDos, siempre igual. (Ni con joystick kempston).

También he montado la Mist, ya que estoy trasteando :) Y nada.... con el último core que va brutal, tampoco se mueve, y con el anterior core de Sorgelig, tampoco va. Todo igual. (Tampoco lo mueve con el joystick kempston en ninguno). He probado con, y sin ESXDos, y cargando desde CSW también.

Es que es muy raro...

En el Spectaculator, ejecutando el juego, igual, no lo mueves, AHORA, que con kempston, SI VA.

VALE.... tras mil pruebas y gracias a probarlo en FUSE (gracias chernandezba), (donde sí va siempre), me he dado cuenta de qué leches pasa realmente:

El juego detecta si tienes insertado un interface joystick kempston en la máquina, y desactiva el control por cursores si es así.

Que en Zesarux vaya la primera vez y las siguientes no, ni idea... pero al menos, ya sé el porqué no va en estas fpga...

Se podrá desactivar interface kempston en la ZXUno? (Si es que lo lleva por defecto)... :?

Mira que tener tanto cacharro y tener que jugar en el emulador de pc... xDDD Es que soy de lo que no hay...

Un saludo.
Vintagenarios powaaa!

Avatar de Usuario
carmeloco
Mensajes: 749
Registrado: 25 Dic 2015, 12:02

Re: El Premio.tap

Mensaje por carmeloco » 23 Abr 2016, 22:59

A mi en Spectaculator y en fuse, me funciona siempre, pero en un :zxuno: real, no me funciona ni desactivando los joysticks con .joyconf

Responder