ZEsarUX 5.0

Software para o relacionado con el core ZX Spectrum / Software for or related to the ZX Spectrum core
Avatar de Usuario
chernandezba
Mensajes: 832
Registrado: 02 Oct 2015, 23:35

ZEsarUX 5.0

Mensaje por chernandezba » 21 Abr 2017, 20:50

Hola!

Ya ha salido ZEsarUX 5.0! :)

Se puede descargar desde la URL:
https://sourceforge.net/projects/zesarux/

Finalmente he conseguido emular el Sinclair QL. He dedicado montones de horas intentando adivinar como funcionaba el teclado.
Hay muy poca documentación y he tenido que hacer montones de desensamblajes de la ROM y testeos de teclado para saber como funciona…
Finalmente… ha sido un duro trabajo… esto es un salto enorme, un "Quantum Leap", y por eso esto es una versión mayor, la 5.0!

Lista completa de cambios:

Added Sinclair QL emulation
Added remote command protocol. You can do enhanced debugging on ZEsarUX by using a telnet client.
There are a lot of commands, even many commands exclusive to this protocol and not found on the GUI, like:
* load-source-code
* hexdump-internal
* set-register

Added Easter Egg ;)
Added Specdrum emulation
Added RZX playback support
Added Multiface One, 128 and Three emulation
Added setting to write configuration file
Added menu item to reload IDE and MMC contents from file. You can now modify a used file outside the emulator and reload its contents
Added autosave snapshot at fixed interval
Added hardware debug port to output ascii characters or numbers directly on host console
Added two unused ports from the ZXI pool for some internal ZEsarUX features. See docs/zesarux_zxi_registers.txt
Added Hotswap from 128k to +2A, and +2A to 128k
Added File Viewer
Added support for drag&drop on Mac OS X, SDL2
Added support for OpenGL rendering on Mac OS X Cocoa driver
Added drawn piano for AY Piano menu setting (on all video drivers except text drivers)
Added Man Software GUI Style
Added setting to change DivIDE/DivMMC eprom firmware file
Added setting to allow writing to DivIDE/DivMMC eprom firmware
Added setting to disable autoframeskip
Added setting to set breakpoints from command line
Added setting to deny changing turbo mode when booting ZX-Uno and on bios
Added setting to disable beeper
Improved Debug CPU Window: now you can switch between different views:
1) 1 opcode, cpu registers, other internal registers
2) 9 opcodes, other internal registers
3) 15 opcodes
4) 9 hexdump lines, other internal registers
5) 15 hexdump lines
Fixed text to speech routine when sending non-ascii character
Fixed bug reading ULAplus register 64
Fixed bugs paging DivIDE/DivMMC
Fixed starting display row on ZX80/81/ACE, with border disabled and realvideo mode (was broken since 4.0)
Fixed reading from paging port on 128k and +2 machines: in this case, the same value read from the idle bus port is sent to the paging port
Fixed setting timings changing from Pentagon to non Pentagon machine
Fixed bug mapping real joystick buttons and axes with same number
Fixed bug when Jupiter Ace machine and border disabled
Updated Z88 OZ V4.7
Some other minor bugfixes and improvements
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

t0lk13n
Mensajes: 24
Registrado: 04 Dic 2016, 15:40

Re: ZEsarUX 5.0

Mensaje por t0lk13n » 21 Abr 2017, 21:27

Deseando probarlo. Muchas gracias!

Avatar de Usuario
chernandezba
Mensajes: 832
Registrado: 02 Oct 2015, 23:35

Re: ZEsarUX 5.0

Mensaje por chernandezba » 21 Abr 2017, 22:53

De nada :)
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
bakoulis
Mensajes: 187
Registrado: 12 Sep 2016, 10:36

Re: ZEsarUX 5.0

Mensaje por bakoulis » 21 Abr 2017, 23:10

Yeahhhh!
:gracias!: :maestro:

EDIT:
QL Emulation gives me a black blank screen. The menus works but the screen is blank and black.
Linux Mint 32Bit Mate.
:(

Avatar de Usuario
chernandezba
Mensajes: 832
Registrado: 02 Oct 2015, 23:35

Re: ZEsarUX 5.0

Mensaje por chernandezba » 21 Abr 2017, 23:34

Maybe the window size is not big enough? Try resizing it and/or pressing F1 when booting QL
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
bakoulis
Mensajes: 187
Registrado: 12 Sep 2016, 10:36

Re: ZEsarUX 5.0

Mensaje por bakoulis » 21 Abr 2017, 23:53

chernandezba escribió:Maybe the window size is not big enough? Try resizing it and/or pressing F1 when booting QL
You have right!
:oops:
Now works, great. But after F1 or F2 It gives some strange letters on cursor!
:shock:
Screenshot.jpg
The keyboard isn't 100% mapped?
I can't find the keys { } [ ] ; : " ' , . / < > ? - + = \

Anyway is an amazing work. I am sure the next versions will be perfect!
:gracias!:

Avatar de Usuario
chernandezba
Mensajes: 832
Registrado: 02 Oct 2015, 23:35

Re: ZEsarUX 5.0

Mensaje por chernandezba » 22 Abr 2017, 01:58

These strange letters are "normal". They appear because of the non-implemented microdrive... it will be fixed in the future ;)
These keys should appear on their natural positions (right to key 0 for example) but try changing Keymap from settings-hardware menu if they don't appear

Cheers
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
bakoulis
Mensajes: 187
Registrado: 12 Sep 2016, 10:36

Re: ZEsarUX 5.0

Mensaje por bakoulis » 22 Abr 2017, 10:08

My keyboard is US/GR layout.
Anyway all the alphabetic and numeric symbols is present to the right places.
Also the symbols over the numbers is to the right places.
The problem is with symbol keys. At first none of the symbol keys work. If I go to menu/settings/hardware/keyboard and play with spanish/default (no matter what) some of the symbol keys start to work as:
Right to "0" normally is the "-" with "_" but have "?" with "/"
Next is the "=" with "+" which is blank! Also the next "\" with "|" is blank.
Right to the "P" is the "[" with "{" and the "]" with "}" both are blank.
Right to "L" is the ":" with ";" which is blank. Next the " " " with " ' " it have "-" and "_"
Right to "M" the "," with "<" and "." with ">" works good, but next the "/" with "?" is empty/blank.
Also the key "<" with ">" left to "Z" is blank.

Avatar de Usuario
chernandezba
Mensajes: 832
Registrado: 02 Oct 2015, 23:35

Re: ZEsarUX 5.0

Mensaje por chernandezba » 22 Abr 2017, 12:52

It's strange. It has been tested on Linux with Xwindow and SDL driver and both work. I suppose the problem is the keyboard locale configuration...
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://github.com/chernandezba/zesarux

Avatar de Usuario
bakoulis
Mensajes: 187
Registrado: 12 Sep 2016, 10:36

Re: ZEsarUX 5.0

Mensaje por bakoulis » 22 Abr 2017, 14:32

chernandezba escribió:It's strange. It has been tested on Linux with Xwindow and SDL driver and both work. I suppose the problem is the keyboard locale configuration...
What distro you have used?
My distro is the Linux Mint 17.3 32bit MATE. Is the most popular distro and binary compatible with Ubuntu and Debian.

Responder