MIST AGA funcionando en placa UnAmiga

Otras placas, clones o aparatos basados en FPGA / Oher FPGA based clones/devices/boards
Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor Dotoro » 12 Ago 2018, 16:31

jepalza escribió:para cargar discos duros "HDF" necesitas al menos KICK2.0 de un A600, no sirve KICK 1.3 de A500

I still cant run MiST AGA core,
TS-conf work fine (zxevo rom loads, wild commander starts), but MiST can't start =(
i start it once with no reason why, but when i turn off power it not start again,
i try SD-Formatter, Gparted on linux and native Windows XP format.
symptoms is look like pink clean screen and freeze. Is it problem with my green board or altera board?
But why TS-conf works with no problems?
Hope you can help me find problem.
+ ScrLk button works and can switch video modes.

Avatar de Usuario
antoniovillena
Mensajes: 2553
Registrado: 27 Sep 2015, 20:41

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor antoniovillena » 13 Ago 2018, 02:43

Dotoro escribió:
jepalza escribió:para cargar discos duros "HDF" necesitas al menos KICK2.0 de un A600, no sirve KICK 1.3 de A500

I still cant run MiST AGA core,
TS-conf work fine (zxevo rom loads, wild commander starts), but MiST can't start =(
i start it once with no reason why, but when i turn off power it not start again,
i try SD-Formatter, Gparted on linux and native Windows XP format.
symptoms is look like pink clean screen and freeze. Is it problem with my green board or altera board?
But why TS-conf works with no problems?
Hope you can help me find problem.
+ ScrLk button works and can switch video modes.


Try different SD files. There are 5 precompiled in this thread:

viewtopic.php?f=27&t=2078

Search "SD Amiga" and mega.nz links
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
jepalza
Mensajes: 610
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor jepalza » 13 Ago 2018, 08:30

Dotoro escribió:I still cant run MiST AGA core,


¿puedes ver la pantalla de inicio del kickstart? (no importa version, puede ser 1.3, 2.0 o 3.1)
Si ves esa pantalla y la tecla F12 funciona (menu OSD aparece), entonces, TODO ESTA CORRECTO, no hay fallo posible.

Dotoro escribió:+ ScrLk button works and can switch video modes.

Con mas razón todavía: si funciona esa tecla, el código UnAmiga está funcionando perfectamente. La tarjeta SD es correcto, por que ha podido cargar el menu OSD, y el teclado funciona. Imagino que la salida de vídeo también funciona.

Si has llegado a este punto, para cargar discos duros virtuales con extensión .HDF, solo necesitas un KICK 2.0 (A600 minimo) de tamaño 512k, entrar en menu OSD con tecla F12, activar el uso de discos duros, y cargar cualquier HDF, reiniciar minimig, y nada mas.

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor Dotoro » 13 Ago 2018, 10:36

No i dont see kickstart screen,
i try all sd files from Antoniovillena topic,
And i use latest MiST AGA 4 core and bin from it.
I will try different kickstart versions.

Avatar de Usuario
jepalza
Mensajes: 610
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor jepalza » 13 Ago 2018, 13:11

Dotoro escribió:No i dont see kickstart screen,
i try all sd files from Antoniovillena topic,
And i use latest MiST AGA 4 core and bin from it.
I will try different kickstart versions.



Entonces, no puedo ayudar mas. Es tan sencillo como un fichero llamado KICK.ROM (version 1.3 de 512k) y el fichero DE1_BOOT.BIN en la SD, fromateada con SD_FORMATTER (https://www.sdcard.org/downloads/formatter_4/)
Nada mas, solo esas tres cosas. Si con eso no funciona, no puedo ayudar mas :(

Avatar de Usuario
antoniovillena
Mensajes: 2553
Registrado: 27 Sep 2015, 20:41

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor antoniovillena » 13 Ago 2018, 13:30

Si usas el último core de MiST_AGA aparte de grabar el .jic debes copiar el DE1_BOOT.BIN en la SD
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor Dotoro » 14 Ago 2018, 21:08

Anyone have same problem?
I try all sd version from Antoniovillena topic,
i used kick 1.3,
it actually behave same as no sd card inserted.
But there is sd card, and it works, i was able to copy delete create dir in ts-conf core.

Dotoro
Mensajes: 33
Registrado: 16 Jul 2018, 19:53

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor Dotoro » 14 Ago 2018, 21:32

antoniovillena escribió:Si usas el último core de MiST_AGA aparte de grabar el .jic debes copiar el DE1_BOOT.BIN en la SD

In what pins i need connect secons small board?

Avatar de Usuario
jepalza
Mensajes: 610
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor jepalza » 14 Ago 2018, 21:38

Dotoro escribió:
antoniovillena escribió:Si usas el último core de MiST_AGA aparte de grabar el .jic debes copiar el DE1_BOOT.BIN en la SD

In what pins i need connect secons small board?


No es obligatorio, si no lo conectas, el amiga funciona igual.

para conectar la segunda placa, lo mejor es una foto. Espera un poco, y hago una foto. :P

Imagen

Avatar de Usuario
jepalza
Mensajes: 610
Registrado: 02 Oct 2015, 18:52

Re: MIST AGA funcionando en placa UnAmiga

Mensajepor jepalza » 14 Ago 2018, 21:48

Tienes que pones el conector pequeño, en los pines de 3.3v (quitando el "jumper" original)

Por cierto: diles a tus amigos del foro, que los fuentes los publicaré en breve, en cuanto organice todo el trabajo. Piensa que he hecho varios cores en poco tiempo, y no he tenido tiempo de organizar las cosas. ;)

http://zx-pk.ru/threads/29327-unamiga.html


Volver a “Otros sistemas FPGA / Another FPGA systems”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado