Actualización conjunta experimental de Firmware 0.75 y core EXP26

Avatar de Usuario
antoniovillena
Mensajes: 2546
Registrado: 27 Sep 2015, 20:41

Re: RE: Re: Actualización conjunta experimental de Firmware 0.73 y core EXP26

Mensajepor antoniovillena » 29 May 2018, 21:55

Kristatos escribió:
antoniovillena escribió:Esa versión solo funciona con el addon de memoria externo. Si no tienes dicho addon no te va a arrancar. Tendrías que desbriquear.


Mecachis... yo también la he cagado pensando que al tener los 2 megas tenía que usar el otro firmware y ahora tengo mi querido zx-uno brickeado :lloron:

Tengo un programador usb xilinx con su juegos de cables. ¿Eso me sirve? No lo he usado en mi vida. ¿Algún enlace a foro o tutorial donde se indiquen instrucciones para desbliquear con el Xilinx en lugar de la Raspberry o cable Altera?

Un saludo.
Se trata de cargar el recovery.bit con una SD con los ficheros necesarios, preferiblemente flash.zx1. Lo único que te tienes que instalar el ise webpack y usar la herramienta impact. En este foro no recuerdo que haya tutorial para esto, pero en Youtube hay bastantes tutoriales para manejar impact.

Enviado desde mi MI 5C mediante Tapatalk
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

mannycalavera
Mensajes: 8
Registrado: 05 Ene 2018, 19:54

Re: Actualización conjunta experimental de Firmware 0.73 y core EXP26

Mensajepor mannycalavera » 07 Ago 2018, 17:09

Tengo un pequeño problema después de actualizar. En su momento instalé el core exp26. Como he visto que había problemas actualizando por separado he seguido las instrucciones del último enlace preparado para actualizar core y bios. He puesto en la bios antes de actualizar el teclado en default. He hecho el .corebios y se ha actualizado correctamente. He vuelto a poner el teclado en español, pero ahora, la primera vez que enciendo desde la corriente, el teclado debe tener otra configuración distinta porque no puedo poner las “ con may+2 (creo que se pone en modo spectrum). Si entro en la bios y salgo aunque sea sin hacer cambios, el teclado vuelve a funcionar correctamente. Una vez hecho esto si hago hard reset sigue funcionando bien.

Es decir, el teclado no funciona como español cuando se enciende desde la corriente y no se entra en bios.

¿Algo que esté haciendo mal?

Edito: he estado haciendo pruebas, instalando otra vez la actualización y ahora cuando hago hard reset el teclado siempre arranca en modo spectrum. Si entro en la bios y salgo sin guardar sigue iniciándose correcto en modo español.

Edito 2: me he dado cuenta que si pongo el teclado en default el layout se pone en inglés cuando hago un hard reset (al iniciar con guardar y salir funciona en layout spectrum) y así se queda aunque apague de la corriente. Si entro en la bios aunque no guarde nada vuelve a pasar lo mismo, la primera vez funciona como layout spectrum y si hago hard reset ya se queda en inglés.

Esto es de locos. Resumiendo:

-Si pongo layout default al guardar y salir inicia en layout spectrum, pero al hacer un hard reset se pone en layout inglés y así se queda aunque desconecte de la corriente. Si entro en la bios aun sin hacer nada, la primera vez inicia como spectrum y al hacer hard reset como inglés.

-Si pongo layout español al guardar y salir inicia en layout español, pero al hacer un hard reset o desconectar de la corriente funciona en layout spectrum. Si vuelvo a entrar en la bios aunque no cambie nada inicia otra vez en español.

-Si pongo layout ingles, comportamiento normal, incia en inglés y se mantiene aunque apague.

Avatar de Usuario
antoniovillena
Mensajes: 2546
Registrado: 27 Sep 2015, 20:41

Re: Actualización conjunta experimental de Firmware 0.73 y core EXP26

Mensajepor antoniovillena » 28 Ago 2018, 00:02

Perdón por la tardanza en contestar. Este bug ya me lo reportó McLeod y lo acabo de arreglar. Prueba a actualizar el FIRMWARE.ZX1 (versión 0.75).

mannycalavera escribió:Tengo un pequeño problema después de actualizar. En su momento instalé el core exp26. Como he visto que había problemas actualizando por separado he seguido las instrucciones del último enlace preparado para actualizar core y bios. He puesto en la bios antes de actualizar el teclado en default. He hecho el .corebios y se ha actualizado correctamente. He vuelto a poner el teclado en español, pero ahora, la primera vez que enciendo desde la corriente, el teclado debe tener otra configuración distinta porque no puedo poner las “ con may+2 (creo que se pone en modo spectrum). Si entro en la bios y salgo aunque sea sin hacer cambios, el teclado vuelve a funcionar correctamente. Una vez hecho esto si hago hard reset sigue funcionando bien.

Es decir, el teclado no funciona como español cuando se enciende desde la corriente y no se entra en bios.

¿Algo que esté haciendo mal?

Edito: he estado haciendo pruebas, instalando otra vez la actualización y ahora cuando hago hard reset el teclado siempre arranca en modo spectrum. Si entro en la bios y salgo sin guardar sigue iniciándose correcto en modo español.

Edito 2: me he dado cuenta que si pongo el teclado en default el layout se pone en inglés cuando hago un hard reset (al iniciar con guardar y salir funciona en layout spectrum) y así se queda aunque apague de la corriente. Si entro en la bios aunque no guarde nada vuelve a pasar lo mismo, la primera vez funciona como layout spectrum y si hago hard reset ya se queda en inglés.

Esto es de locos. Resumiendo:

-Si pongo layout default al guardar y salir inicia en layout spectrum, pero al hacer un hard reset se pone en layout inglés y así se queda aunque desconecte de la corriente. Si entro en la bios aun sin hacer nada, la primera vez inicia como spectrum y al hacer hard reset como inglés.

-Si pongo layout español al guardar y salir inicia en layout español, pero al hacer un hard reset o desconectar de la corriente funciona en layout spectrum. Si vuelvo a entrar en la bios aunque no cambie nada inicia otra vez en español.

-Si pongo layout ingles, comportamiento normal, incia en inglés y se mantiene aunque apague.
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
carmeloco
Mensajes: 742
Registrado: 25 Dic 2015, 12:02

Re: Actualización conjunta experimental de Firmware 0.75 y core EXP26

Mensajepor carmeloco » 13 Sep 2018, 15:36

He probado a hacer un archivo de actualización de BIOS en formato vertical, poniendo a 1 el parámetro "define vertical" de firmware.asm, y en el menú de upgrade, no funcionan las actualizaciones de BIOS ni de FLASH. Da un error como si no encontrase el archivo o el tamaño fuese incorrecto, pero ese mismo archivo de FLASH, lo actualizo desde el core de Spectrum en modo rooted con .upgrade, y se actualiza correctamente.

Avatar de Usuario
antoniovillena
Mensajes: 2546
Registrado: 27 Sep 2015, 20:41

Re: Actualización conjunta experimental de Firmware 0.75 y core EXP26

Mensajepor antoniovillena » 13 Sep 2018, 18:00

carmeloco escribió:He probado a hacer un archivo de actualización de BIOS en formato vertical, poniendo a 1 el parámetro "define vertical" de firmware.asm, y en el menú de upgrade, no funcionan las actualizaciones de BIOS ni de FLASH. Da un error como si no encontrase el archivo o el tamaño fuese incorrecto, pero ese mismo archivo de FLASH, lo actualizo desde el core de Spectrum en modo rooted con .upgrade, y se actualiza correctamente.


Puede que hayas compilado para ZXDOS. Asegúrate de que tienes un fichero version.asm con el contenido " define version 1". Acabo de crear binarios verticales en el repo. Puedes comparar con este archivo:

https://github.com/antoniovillena/zxuno ... rtical.ZX1
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
carmeloco
Mensajes: 742
Registrado: 25 Dic 2015, 12:02

Re: Actualización conjunta experimental de Firmware 0.75 y core EXP26

Mensajepor carmeloco » 13 Sep 2018, 22:14

antoniovillena escribió:
carmeloco escribió:He probado a hacer un archivo de actualización de BIOS en formato vertical, poniendo a 1 el parámetro "define vertical" de firmware.asm, y en el menú de upgrade, no funcionan las actualizaciones de BIOS ni de FLASH. Da un error como si no encontrase el archivo o el tamaño fuese incorrecto, pero ese mismo archivo de FLASH, lo actualizo desde el core de Spectrum en modo rooted con .upgrade, y se actualiza correctamente.


Puede que hayas compilado para ZXDOS. Asegúrate de que tienes un fichero version.asm con el contenido " define version 1". Acabo de crear binarios verticales en el repo. Puedes comparar con este archivo:

https://github.com/antoniovillena/zxuno ... rtical.ZX1

Muchas gracias :okidoki;
Efectivamente, era eso. Ni me había fijado en el cambio del logo al estar en vertical, y el monitor en horizontal.
Desconocía lo del archivo de versiones y lo dejé tal y como estaba en tu repositorio.

Por cierto, ya que estamos, ¿cuales son los cambios con respecto a la 0.73?

Avatar de Usuario
antoniovillena
Mensajes: 2546
Registrado: 27 Sep 2015, 20:41

Re: Actualización conjunta experimental de Firmware 0.75 y core EXP26

Mensajepor antoniovillena » 13 Sep 2018, 22:22

carmeloco escribió:Por cierto, ya que estamos, ¿cuales son los cambios con respecto a la 0.73?

En la 0.74 añadí segundo botón de joystick a la BIOS (hace funciones de tecla Escape). Y en la 0.75 arreglé un bug que interpretaba mal el layout de teclado, introducido en la 0.73.
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
carmeloco
Mensajes: 742
Registrado: 25 Dic 2015, 12:02

Re: Actualización conjunta experimental de Firmware 0.75 y core EXP26

Mensajepor carmeloco » 13 Sep 2018, 23:10

antoniovillena escribió:
carmeloco escribió:Por cierto, ya que estamos, ¿cuales son los cambios con respecto a la 0.73?

En la 0.74 añadí segundo botón de joystick a la BIOS (hace funciones de tecla Escape). Y en la 0.75 arreglé un bug que interpretaba mal el layout de teclado, introducido en la 0.73.

Perfecto :gracias!:


Volver a “Firmware”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado