Luz verde y Roja en el ZX-Uno del crowdfunding

Discursiones en general sobre el proyecto que no tienen cabida en otro foro / General discussion for uncateorized topics about the ZX-Uno project
Avatar de Usuario
antoniovillena
Mensajes: 2591
Registrado: 27 Sep 2015, 20:41

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor antoniovillena » 04 Feb 2019, 10:51

jsj escribió:Gracias. Tendré que usar el de 4Mb ya que no está modificado.

Una pregunta: ¿cuántos "cores" soporta el ZX-UNO de 4Mb? Es que desde la BIOS, después de meter el firmware 0.76 por el método descrito con "COREBIOS", me dejó meter hasta ¿13?. Y creo que es ha sido el problema y la causa del "brick". ¿No debería haberme limitado la BIOS a menos? ¿o es algo que no está controlado?


En teoría está limitado a 9 y no debería dejarte meter más. La BIOS detecta el tamaño de la flash y pone el límite a 9 ó 45. Lo que te ha pasado será por un bug no detectado hasta ahora.
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
jsj
Mensajes: 335
Registrado: 21 Nov 2015, 12:48

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor jsj » 06 Mar 2019, 20:40

He probado a desbrickear mi ZX-Uno del crowdfunding siguiendo el método del cable USB-Blaster. De hecho le pedí uno directamente a Antonio para la versión 4.1 (ya que creo que es el que vale para mi placa).

He seguido los pasos de la FAQ, de los posts que hay en este mismo foro y nada.

Lo primero, conecto el cable USB-Blaster, lo enchufo al USB del PC y enciendo el ZX-Uno.

Imagen

Aquí una vista general de todo conectado.

Imagen

Ejecuto "jtag" desde línea de comandos, sigo los pasos y se me queda fijo en la siguiente pantalla. En la FAQ pone esperar un minuto porque el proceso tarda. Pues yo llevo ya esperando más de 10 minutos y la cosa sigue así...

Imagen

He probado el "recovery.bit" que venía en el ZIP del UrJTAG, el "recovery.46.bit" y el "recovery.73.bit" que me he encontrado por el foro mirando los mensajes. Con todos ellos me pasa lo mismo. Varía el "Bitstream information" que sale cuando se hace el "pld load" pero con los 3 bitstreams se me queda fijo ahí.

Ya no sé que probar. A ver si alguno puede orientarme... :lloron: :lloron: :lloron:

Avatar de Usuario
antoniovillena
Mensajes: 2591
Registrado: 27 Sep 2015, 20:41

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor antoniovillena » 06 Mar 2019, 23:01

jsj escribió:He probado a desbrickear mi ZX-Uno del crowdfunding siguiendo el método del cable USB-Blaster. De hecho le pedí uno directamente a Antonio para la versión 4.1 (ya que creo que es el que vale para mi placa).
...
Ya no sé que probar. A ver si alguno puede orientarme... :lloron: :lloron: :lloron:


Pues vas bien porque la fpga te la detecta. El problema está en el comando pld, que se queda atascado. Te recomiendo que lo enchufes a una TV por video compuesto. Y también que uses el recovery.73.bit, ya que carga directamente el FLASH.ZX1 sin preguntar ni nada. O sea que tampoco necesitas conectar el teclado. Simplemente observa la TV tras el comando pld hasta que funcione.
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
jsj
Mensajes: 335
Registrado: 21 Nov 2015, 12:48

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor jsj » 07 Mar 2019, 21:20

He probado a enchufar por vídeo compuesto. He usado el recovery.73.bit. Pero nada de nada... la pantalla de la TV se queda en negro (en realidad en una tonalidad verde oscura (casi como los monitores de fósforo verde de la época).

He probado a desinstalar y reinstalar los drivers del USB Blaster también y nada. A cambiar el cable USB. Incluso he probado en otros puertos USB.

Ya se me están acabando las opciones. La única que se me ocurre es probar desde Linux. Pero me jode porque tengo que montarlo ya que ahora mismo no tengo ningún PC con Linux. :quemecuentas:

nch
Mensajes: 76
Registrado: 10 Ene 2018, 23:16

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor nch » 07 Mar 2019, 22:08

En cuanto a linux, puedes usar un live usb de manjaro (por ejemplo) en el que puedes instalar aur/urjtag-git en un momento. Supongo que como root deberías poder hacer todo sin problemas de permisos con respecto al usb-blaster. No te debería llevar mas de 15-20 minutos.

Avatar de Usuario
jsj
Mensajes: 335
Registrado: 21 Nov 2015, 12:48

Re: Luz verde y Roja en el ZX-Uno del crowdfunding

Mensajepor jsj » 08 Mar 2019, 12:31

Si, probaré este fin de semana en cuanto saque un rato. A ver si con ese procedimiento consigo "despertar" al ZX-Uno. :smashPC:


Volver a “General / Uncategorized”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados