Sugarless +2 (A ZX-Uno Companion)

Proyectos ajenos al equipo oficial pero desarrollados o promovidos por la comunidad, relacionados con el ZX-UNO / Projects outside the official team but developed or promoted by the community, related to the ZX-UNO
jevilon
Mensajes: 339
Registrado: 24 Mar 2016, 12:26

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por jevilon » 17 Abr 2018, 07:50

Lo curioso es que al conectar el cable de video compuesto.... el ruido (solo audio si) desaparece.... incluso en border 7... no se... parece que al conectarlo hace masa y ya no suena... quizás tenga algun corto o alguna mala soldadura?

Avatar de Usuario
spark2k06
Mensajes: 1136
Registrado: 12 Feb 2016, 13:58

Re: RE: Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por spark2k06 » 17 Abr 2018, 07:55

jevilon escribió:Lo curioso es que al conectar el cable de video compuesto.... el ruido (solo audio si) desaparece.... incluso en border 7... no se... parece que al conectarlo hace masa y ya no suena... quizás tenga algun corto o alguna mala soldadura?
Has probado a cambiar de border a ver si también desaparece?

Edito: Por cierto, a mi también se me reduce algo el ruido de border 7 cuando la masa del RCA del TV es conectada a la de Sugarless... no creo que tenga nada que ver con ninguna soldadura. Como digo, en cualquier otro border, el ruidillo desaparece.

Enviado desde mi Thor mediante Tapatalk

jevilon
Mensajes: 339
Registrado: 24 Mar 2016, 12:26

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por jevilon » 17 Abr 2018, 08:42

No, estoy fuera de casa, a la hora de comer lo miro y te digo.

Por cierto dejo una foto de mi sugarless...
Los jumper del casette están sin poner, puesto que al ser un plus 3 no lo voy a usar, estuve tentado de no poner tampoco los pines, pero bueno nunca se sabe, y ya que están....

El tema del teclado lo he solucionado con 6 cables dupont macho macho, cortando un poco la puntita para que entren hasta el fondo.
Adjuntos
IMG-20180416-WA0018.jpeg

Avatar de Usuario
spark2k06
Mensajes: 1136
Registrado: 12 Feb 2016, 13:58

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por spark2k06 » 17 Abr 2018, 09:37

jevilon escribió: Por cierto dejo una foto de mi sugarless...
Los jumper del casette están sin poner, puesto que al ser un plus 3 no lo voy a usar, estuve tentado de no poner tampoco los pines, pero bueno nunca se sabe, y ya que están....
Lo tienes bien organizado ;-)
jevilon escribió: El tema del teclado lo he solucionado con 6 cables dupont macho macho, cortando un poco la puntita para que entren hasta el fondo.
Puedes usar solo los 4 para las señales (y puedes conectar cables hembra al conector de 4 pines que hay justo detrás del PS/2) y llevar un sólo cable de +5V (GND ya entra por otros conectores) del conector dupont donde hay dos pines de +5V y otros dos de GND al lado del conector de TAPE, al +5V de POWER del ZX-Uno, para ello tendrías que soldar en éste sus pines de POWER (al lado del conector de microUSB del mismo). Con esto te aseguras que los +5V pasan por el inductor que hay en esa entrada, en lugar de evitarla metiendo los +5V por el conector PS/2 del ZX-Uno... hay posibilidades de que el ruido que pueda provenir de la fuente de alimentación te desaparezca así, en caso de que sea el origen del mismo.

jevilon
Mensajes: 339
Registrado: 24 Mar 2016, 12:26

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por jevilon » 17 Abr 2018, 10:00

Entonces tendría que quitar los pines 3 y 4 ( los del medio en altura)?

Avatar de Usuario
spark2k06
Mensajes: 1136
Registrado: 12 Feb 2016, 13:58

Re: RE: Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por spark2k06 » 17 Abr 2018, 10:05

jevilon escribió:Entonces tendría que quitar los pines 3 y 4 ( los del medio en altura)?
Exacto.

En los dos pines de power del zxuno, asegurate bien de cuál es el de +5V.


Imagen

Enviado desde mi Thor mediante Tapatalk

jevilon
Mensajes: 339
Registrado: 24 Mar 2016, 12:26

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por jevilon » 17 Abr 2018, 10:11

Pues si, lo haré, así meto corriente dónde corresponde.

Cuál es el de 5 v?? Jeje, bueno supongo que conectando el microusb y midiendo con el tester lo sabré, creo que así hice el zxuno inside.

Otra cosa que me he acordado, hay un conector led, le he puesto el led del plus 3 y se enciende una miaja, inapreciable, pensé, será por la resistencia que lleva, la puenteo a ver... Y sigue encendido nada. Una miaja de nada, casi inapreciable...

Avatar de Usuario
spark2k06
Mensajes: 1136
Registrado: 12 Feb 2016, 13:58

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por spark2k06 » 17 Abr 2018, 10:28

jevilon escribió:Pues si, lo haré, así meto corriente dónde corresponde.

Cuál es el de 5 v?? Jeje, bueno supongo que conectando el microusb y midiendo con el tester lo sabré, creo que así hice el zxuno inside.

Otra cosa que me he acordado, hay un conector led, le he puesto el led del plus 3 y se enciende una miaja, inapreciable, pensé, será por la resistencia que lleva, la puenteo a ver... Y sigue encendido nada. Una miaja de nada, casi inapreciable...
Sí, mide con el tester para asegurarte bien.

Respecto al LED, Un pin es GND y el otro procede de una I/O del arduino. Como estos pines de arduino proporcionan una intensidad muy baja, es normal que la resistencia que hay en la plaquita del LED del +3 pueda resultar demasiado alta. Me parece raro que puenteandola se te siga viendo igual, pero yo no haría eso, una resistencia aunque sea mínima creo que debería tener... habría que buscar el valor adecuado para la intensidad que proporciona el arduino y el tipo de LED del +3.

jevilon
Mensajes: 339
Registrado: 24 Mar 2016, 12:26

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por jevilon » 17 Abr 2018, 10:44

Si, el puentearla fue un momento para probar, de todas formas probaré con otro led, no sea que esté tocado.

Jo, vaya chapa te estoy dando, solo espero que estás cosas sirvan para los que vayan montando después

Avatar de Usuario
Uto
Mensajes: 1385
Registrado: 17 Dic 2015, 16:39

Re: ZX-Uno dentro de un +2/+3, progresos

Mensaje por Uto » 17 Abr 2018, 10:49

spark2k06 escribió:
jevilon escribió:Pues si, lo haré, así meto corriente dónde corresponde.

Cuál es el de 5 v?? Jeje, bueno supongo que conectando el microusb y midiendo con el tester lo sabré, creo que así hice el zxuno inside.

Otra cosa que me he acordado, hay un conector led, le he puesto el led del plus 3 y se enciende una miaja, inapreciable, pensé, será por la resistencia que lleva, la puenteo a ver... Y sigue encendido nada. Una miaja de nada, casi inapreciable...
Sí, mide con el tester para asegurarte bien.

Respecto al LED, Un pin es GND y el otro procede de una I/O del arduino. Como estos pines de arduino proporcionan una intensidad muy baja, es normal que la resistencia que hay en la plaquita del LED del +3 pueda resultar demasiado alta. Me parece raro que puenteandola se te siga viendo igual, pero yo no haría eso, una resistencia aunque sea mínima creo que debería tener... habría que buscar el valor adecuado para la intensidad que proporciona el arduino y el tipo de LED del +3.
Yo me encontré con la misma situacion, y cambié una resistencia de 500 por una de 300, pero lo mismo no se nota el cambio. Pero eso es así si miras el led de lado, que ves un puntito ahí, prueba a poner el led en su sitio y mirarlo por arriba de la carcasa, verás que la diferencia sí se aprecia. Tampoco brilla mucho, pero se ve claramente en contraste con el negro de la carcasa si está encendido o no.

Responder