TEST2: listo para que lo probeis

ManuFerHi
Mensajes: 751
Registrado: 15 Nov 2015, 17:50

Re: TEST2: listo para que lo probeis

Mensaje por ManuFerHi » 10 Abr 2017, 13:51

Creo que McLeod le ha dado algo de sordera al Zx-Uno en sus últimos cores y posiblemente en este de Amstrad, antes podía cargar con mi móvil Huawei P9 y la app TeeZix sin problema cargaba los .TZX , pero en los últimos cores ya no es posible sin un amplificador de por medio. Creo haber leído que bajó para hacerlo compatible con los TZXduino sin necesidad de amplificador, o sea para igualar la sensibilidad de un Spectrum real.
Ahora uso el Wintzx en el portátil y va muy bien (a tope de volumen en el portátil) y mi portátil tiene buena salida de audio, pero carga todo .tzx y .cdt

paulfiction
Mensajes: 35
Registrado: 19 Jun 2016, 00:14

Re: TEST2: listo para que lo probeis

Mensaje por paulfiction » 10 Abr 2017, 13:57

Buenas he acargado el antiriad y alguno más, en el menu del juego no me responde el teclado ni joystick, lo he puesto en "spanish" en keyboard u fuller en joystick pero no puedo empesar a jugar , alguna idea? gracias

Avatar de Usuario
neuro_999
Mensajes: 692
Registrado: 06 Oct 2015, 10:14

Re: TEST2: listo para que lo probeis

Mensaje por neuro_999 » 10 Abr 2017, 14:18

A mi en el antiriad me ha pasado eso, no me reconoce el disparo del joystick para empezar, pero en el basic si que detecta ambos disparos como z y x. Ya no recuerdo si salia igual en el amstrad original... Y sobre el casete, he pasado una prueba de azimut con el tapdancer y la da perferca. [img]https://uploads.tapatalk-cdn.com/201704 ... fe8093.jpg[/img]

Enviado desde mi ONE A2003 mediante Tapatalk

Avatar de Usuario
mcleod_ideafix
Mensajes: 821
Registrado: 27 Sep 2015, 00:14
Ubicación: Jerez de la Frontera
Contactar:

Re: TEST2: listo para que lo probeis

Mensaje por mcleod_ideafix » 10 Abr 2017, 16:20

ManuFerHi escribió:Creo que McLeod le ha dado algo de sordera al Zx-Uno en sus últimos cores y posiblemente en este de Amstrad
En absoluto. El circuito de EAR es externo a la FPGA. No puedo influir sobre él.
ManuFerHi escribió:Creo haber leído que bajó para hacerlo compatible con los TZXduino sin necesidad de amplificador, o sea para igualar la sensibilidad de un Spectrum real.
¿Que yo hice qué? No tengo siquiera un TZXDuino. Mi única intervención sobre ese asunto fue para responder a alguien que decía que no podía usarlo en el core de Spectrum, y le sugerí que, en el TZXDuino, bypasseara el amplificador y usara directamente la señal de GPIO del Arduino.
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

ManuFerHi
Mensajes: 751
Registrado: 15 Nov 2015, 17:50

Re: TEST2: listo para que lo probeis

Mensaje por ManuFerHi » 10 Abr 2017, 16:35

Por eso he puesto "creo" leí algo sobre ese tema pero perdí el hilo, curiosamente con el T22 puedo cargar con mi móvil, pero con el T24 me da errores de carga como si le faltara un pelín de volumen, y creí que habías modificado la sensibilidad, creo que en el hilo te pedían dejarlo como un spectrum real. Pero me queda claro que no, no se puede.

Avatar de Usuario
antoniovillena
Mensajes: 2603
Registrado: 27 Sep 2015, 20:41

Re: TEST2: listo para que lo probeis

Mensaje por antoniovillena » 10 Abr 2017, 18:55

El problema principal es que a bajo volumen la onda original se distorsiona. Esta distorsión produce unos pulsos más largos que otros. Por ejemplo si en condiciones buenas de volumen tenemos 1ms para pulso bajo y 1ms para pulso alto (medidas inventadas pero aproximadas), con bajo volumen podríamos tener 0.9ms para pulso bajo y 1.1ms para pulso alto. Ya no es la señal simétrica que se espera y dependiendo del algoritmo de carga, ésta puede fallar o no. En el caso de la carga estándar de spectrum las tolerancias son muy altas, por lo que se permite mayor asimetría en la señal. Pero es lo que dice McLeod, el hardware es el mismo y no se puede tocar, y el algoritmo utilizado está codificado en la ROM del sistema, por lo que poco se puede hacer para mejorar la carga a nivel de core.

Avatar de Usuario
desUBIKado
Mensajes: 828
Registrado: 05 Ago 2016, 22:33

Re: TEST2: listo para que lo probeis

Mensaje por desUBIKado » 10 Abr 2017, 21:04

mcleod_ideafix escribió:
desUBIKado escribió:@mcleod_ideafix, en vista de que a ManuFerHi también le pasa el mismo problema que a mi con el Ghosts'N Goblins, ¿puedes probar con la cinta que yo he cargado? Es esta: https://cpcrulez.fr/download.php?a=VISt ... HDj8Wj1NnH
La versión que me dices me funciona igual de bien que la que tenía (creo que son idénticas). Haced como Uto: volved a descargarse el .ZX1 y volver a flashearlo, no sea que de ahí venga el tema.
He hecho de todo y me sigue dando el mismo problema.

Lo he cargado en Android con las aplicaciones tapDancer y AndroCDT2WAV, y lo mismo.

Lo he cargado desde el PC con el CDT2WAV 1.6 de Markus Hohmann y lo mismo.

He descargado de nuevo el core.ZX1 y lo he instalado en otro slot, y lo mismo. Antes hice un md5sum y el hash coincidía con la versión del core que instalé antes.

Lo único diferente es que mi ZX-Uno no es del crowdfunding, sino la versión 4.1 512 KB con salida VGA de ManuFerHi, pero entiendo que eso no debería tener que afectar. Las pruebas que hago son siempre viendo la salida VGA en un monitor compatible 50Hz.

Misterio. :veoestrellas:

ManuFerHi
Mensajes: 751
Registrado: 15 Nov 2015, 17:50

Re: TEST2: listo para que lo probeis

Mensaje por ManuFerHi » 10 Abr 2017, 21:55

desUBIKado escribió:
mcleod_ideafix escribió:
desUBIKado escribió:@mcleod_ideafix, en vista de que a ManuFerHi también le pasa el mismo problema que a mi con el Ghosts'N Goblins, ¿puedes probar con la cinta que yo he cargado? Es esta: https://cpcrulez.fr/download.php?a=VISt ... HDj8Wj1NnH
La versión que me dices me funciona igual de bien que la que tenía (creo que son idénticas). Haced como Uto: volved a descargarse el .ZX1 y volver a flashearlo, no sea que de ahí venga el tema.
He hecho de todo y me sigue dando el mismo problema.

Lo he cargado en Android con las aplicaciones tapDancer y AndroCDT2WAV, y lo mismo.

Lo he cargado desde el PC con el CDT2WAV 1.6 de Markus Hohmann y lo mismo.

He descargado de nuevo el core.ZX1 y lo he instalado en otro slot, y lo mismo. Antes hice un md5sum y el hash coincidía con la versión del core que instalé antes.

Lo único diferente es que mi ZX-Uno no es del crowdfunding, sino la versión 4.1 512 KB con salida VGA de ManuFerHi, pero entiendo que eso no debería tener que afectar. Las pruebas que hago son siempre viendo la salida VGA en un monitor compatible 50Hz.

Misterio. :veoestrellas:
Prueba por vídeo compuesto, yo creo que van por ahí los tiros.

ManuFerHi
Mensajes: 751
Registrado: 15 Nov 2015, 17:50

Re: TEST2: listo para que lo probeis

Mensaje por ManuFerHi » 11 Abr 2017, 22:21

ManuFerHi escribió:
desUBIKado escribió:
mcleod_ideafix escribió:
desUBIKado escribió:@mcleod_ideafix, en vista de que a ManuFerHi también le pasa el mismo problema que a mi con el Ghosts'N Goblins, ¿puedes probar con la cinta que yo he cargado? Es esta: https://cpcrulez.fr/download.php?a=VISt ... HDj8Wj1NnH
La versión que me dices me funciona igual de bien que la que tenía (creo que son idénticas). Haced como Uto: volved a descargarse el .ZX1 y volver a flashearlo, no sea que de ahí venga el tema.
He hecho de todo y me sigue dando el mismo problema.

Lo he cargado en Android con las aplicaciones tapDancer y AndroCDT2WAV, y lo mismo.

Lo he cargado desde el PC con el CDT2WAV 1.6 de Markus Hohmann y lo mismo.

He descargado de nuevo el core.ZX1 y lo he instalado en otro slot, y lo mismo. Antes hice un md5sum y el hash coincidía con la versión del core que instalé antes.

Lo único diferente es que mi ZX-Uno no es del crowdfunding, sino la versión 4.1 512 KB con salida VGA de ManuFerHi, pero entiendo que eso no debería tener que afectar. Las pruebas que hago son siempre viendo la salida VGA en un monitor compatible 50Hz.

Misterio. :veoestrellas:
Prueba por vídeo compuesto, yo creo que van por ahí los tiros.
He vuelto a probar el ghost and goblins esta vez por cable RGB y sí que funciona, por VGA se va la imagen e incluso por RGB usando la entrada VGA del monitor multisync también se va la imagen.

Por cierto... que versión más mala, salta como el manic miner ni siquiera da opción a girar el disparo en el aire.

ManuFerHi
Mensajes: 751
Registrado: 15 Nov 2015, 17:50

Re: TEST2: listo para que lo probeis

Mensaje por ManuFerHi » 13 Abr 2017, 19:04

Esta tarde me he montado un tzxduino y lo he probado con varios juegos, funciona perfectamente sin necesidad de amplificador, conectado directamente al pin del arduino carga bien, he probado en Spectrum y Amstrad.
La Abadía del crimen funciona correctamente sin ningún tipo de fallo encontrado, por cierto gran versión para mi gusto mejor que en Spectrum por el manejo de los colores aunque el movimiento quizás es más lento.
Imagen

Responder