Core PC/XT BETA para ZX-UNOs con 2MB

Avatar de Usuario
spark2k06
Mensajes: 1140
Registrado: 12 Feb 2016, 13:58

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por spark2k06 » 16 Feb 2017, 05:21

Le he añadido un cable de mayor sección al puente (aunque parece por la foto que la de DistWave es aún mayor). También he realizado una comparación de impedancia entre un pin de la memoria interna y FPGA (00.2 - 00.3) y uno de la memoria externa y FPGA (00.5 - 00.6), en ambos hace el pitido el polímetro, pero desconozco la precisión de medición del mismo, no obstante esas son las diferencias que muestra.

Polímetro configurado en 200 ohmios, como se ve en la foto.

He probado de nuevo el core de 50 para la memoria externa con este puente añadido y no ha funcionado, el test de memoria externa lo sigue pasando correctamente.
Adjuntos
IMG_20170216_053316.jpg
IMG_20170216_051027.jpg

Avatar de Usuario
DistWave
Mensajes: 183
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por DistWave » 16 Feb 2017, 14:14

He añadido 4 test más: a 45, 40, 35 y 30 MHz. Si no te funciona ninguno, tienes algo roto (a 30 MHz me funciona correctamente una SRAM de 55 ns conectada con cables al puerto de expansión)

Avatar de Usuario
spark2k06
Mensajes: 1140
Registrado: 12 Feb 2016, 13:58

Re: RE: Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por spark2k06 » 16 Feb 2017, 14:18

DistWave escribió:He añadido 4 test más: a 45, 40, 35 y 30 MHz. Si no te funciona ninguno, tienes algo roto (a 30 MHz me funciona correctamente una SRAM de 55 ns conectada con cables al puerto de expansión)
Si tuviera algo roto entiendo que no se superaría el core de test de 2Mb externos... mañana lo pruebo y comento no obstante. Gracias!

Avatar de Usuario
spark2k06
Mensajes: 1140
Registrado: 12 Feb 2016, 13:58

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por spark2k06 » 16 Feb 2017, 14:34

Una pregunta, en el supuesto de que la SD con el SO estuviese mal grabada, al menos texto tendría que salir verdad? Es decir, incluso sin SD insertada...

Enviado desde mi Thor mediante Tapatalk

Avatar de Usuario
DistWave
Mensajes: 183
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por DistWave » 16 Feb 2017, 14:58

Si, cuando no está la SD insertada aparece la BIOS y un mensaje de error.

No he mirado a fondo el test de memoria, ¿habéis comprobado que no pueda dar falsos positivos? Por ejemplo, si hay una línea de direcciones fija a 1 o 0, una iteración de lectura/escritura no fallaría, pero estaría escribiendo en una posición que no corresponde.

Avatar de Usuario
neuro_999
Mensajes: 692
Registrado: 06 Oct 2015, 10:14

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por neuro_999 » 16 Feb 2017, 15:09

Pero en ese caso la segunda vez que quisiera pintar esa dirección ya saldria pintada., según entiendo el el test original de mcleod. Solo se puede pintar una vez (bien) cada dir, la segunda vez ya aparecería pintada.

Enviado desde mi ONE A2003 mediante Tapatalk

Avatar de Usuario
spark2k06
Mensajes: 1140
Registrado: 12 Feb 2016, 13:58

Re: RE: Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por spark2k06 » 16 Feb 2017, 15:09

DistWave escribió:Si, cuando no está la SD insertada aparece la BIOS y un mensaje de error.

No he mirado a fondo el test de memoria, ¿habéis comprobado que no pueda dar falsos positivos? Por ejemplo, si hay una línea de direcciones fija a 1 o 0, una iteración de lectura/escritura no fallaría, pero estaría escribiendo en una posición que no corresponde.
Sin ver los fuentes, entiendo que debe estar bien. Cada pantalla son 64Kb, durante 32 ciclos (que corresponde a 2Mb), salen pantallas con basura (normal, contenido aleatorio), y van rellenándose lineas. Tras estos 32, vuelven a mostrarse, pero ya en todas se ven las líneas (nada de basura), lo cual, entiendo yo que el test es correcto.

Enviado desde mi Thor mediante Tapatalk

Avatar de Usuario
spark2k06
Mensajes: 1140
Registrado: 12 Feb 2016, 13:58

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por spark2k06 » 17 Feb 2017, 06:29

Ni con 30... evidentemente, algo pasa. Viendo que no observo ninguna anomalía en el test de memoria, lo siguiente que haré sera poner en funcionamiento el reproductor de PZX, a ver que tal. Por otro lado, veremos cómo les va al resto de usuarios que disponen del addon.

Avatar de Usuario
Martin8bity
Mensajes: 36
Registrado: 13 Mar 2016, 09:51
Ubicación: Czech Republic
Contactar:

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por Martin8bity » 17 Feb 2017, 09:54

I replaced the internal 2MB SRAM AS7C316096C-10TIN for IS61WV20488BLL-10TLI and the core seems to be working stable on 75 MHz.

I have just trouble with games. From the few, that I have, only Prince seems to work OK. Even the LSL which seems to be working accoring to info in the cloud spreadsheet is not working to me. Could anyone upload some working games somewhere, so I could test something that should be ok. Thanks.

Avatar de Usuario
Martin8bity
Mensajes: 36
Registrado: 13 Mar 2016, 09:51
Ubicación: Czech Republic
Contactar:

Re: Core PC/XT BETA para ZX-UNOs con 2MB

Mensaje por Martin8bity » 18 Feb 2017, 00:31

I found strange thing. When trying The Cycles (Grand Prix), the 2MB core (does not matter if 50 or 75 MHz) gives me message "Packed files is corrupt", while the same game works with 512kB core quite well. If you want to test, I put it on http://www.8bity.cz/files/PC/CYCLES.zip for download.

Responder