New MSX1 core

fbelavenuto
Mensajes: 100
Registrado: 08 Sep 2016, 13:10

Re: New MSX1 core

Mensaje por fbelavenuto » 18 Nov 2016, 17:16

Oops!! BUG!!!
Vanfanel escribió:@fabio: Great update!! I have been trying PAL games and they run great now!! (For example, Invasion of the Zombie Monsters runs at the right speed now!)

However, if I set PAL in config.txt, and reboot via CTRL+ALT+SUP, I am in NTSC mode again. Could it be a bug?
Resetting via CTRL+ALT+F12 reboots in PAL again.

Vanfanel
Mensajes: 275
Registrado: 16 Oct 2016, 15:50

Re: New MSX1 core

Mensaje por Vanfanel » 18 Nov 2016, 17:19

@fabio: also, PAL color encoding seems to have another bug: it gives black and white image UNLESS you enter the ZX-UNO BIOS before booting in PAL.
If you boot directly, you get black and white PAL image. (My TV is PAL).

fbelavenuto
Mensajes: 100
Registrado: 08 Sep 2016, 13:10

Re: New MSX1 core

Mensaje por fbelavenuto » 18 Nov 2016, 17:57

Strange!

I'll try to fix crystal frequency in 3.57.
Vanfanel escribió:@fabio: also, PAL color encoding seems to have another bug: it gives black and white image UNLESS you enter the ZX-UNO BIOS before booting in PAL.
If you boot directly, you get black and white PAL image. (My TV is PAL).

fbelavenuto
Mensajes: 100
Registrado: 08 Sep 2016, 13:10

Re: New MSX1 core

Mensaje por fbelavenuto » 18 Nov 2016, 21:45

Vanfael, please test the "COREX(BETA).ZX1" file.
fbelavenuto escribió:Strange!

I'll try to fix crystal frequency in 3.57.
Vanfanel escribió:@fabio: also, PAL color encoding seems to have another bug: it gives black and white image UNLESS you enter the ZX-UNO BIOS before booting in PAL.
If you boot directly, you get black and white PAL image. (My TV is PAL).

Vanfanel
Mensajes: 275
Registrado: 16 Oct 2016, 15:50

Re: New MSX1 core

Mensaje por Vanfanel » 19 Nov 2016, 01:59

@fabio:
This version:
-Does not go back to NTSC anymore on CTRL+ALT+SUP. Great!
-Does show colors in PAL mode as expected without having to enter the ZXUNO BIOS menu. Great too!
-There is an invisible area at the lower part of the screen in PAL mode, as if image was too large for TV. This is the only failure I have seen.

Avatar de Usuario
desUBIKado
Mensajes: 761
Registrado: 05 Ago 2016, 22:33

Re: New MSX1 core

Mensaje por desUBIKado » 19 Nov 2016, 22:26

Hola Fabio:

Muchas gracias por tu gran trabajo con este core. Me estoy divirtiendo mucho cargando ficheros .ROM, .CAS y .DSK.

Pero he intentado grabar un programa BASIC desde MSX-BASIC con el comando SAVE "A:HOLA.BAS" y el led rojo de que el ZX-UNO está usando la tarjeta SD parpadea, pero no termina de finalizar la grabación. Si hago RESET (CTRL+ALT+F12) y hago un DIR del directorio raíz veo esto:

Código: Seleccionar todo

HOLA     BAS                          0 15-02-17
 102337K in 28 files      0 bytes free
¿Se puede usar el comando SAVE con tu core?

azesmbog
Mensajes: 235
Registrado: 17 Feb 2016, 23:07

Re: New MSX1 core

Mensaje por azesmbog » 20 Nov 2016, 18:09

Hi, Fabio!
(sorry for my bad english)
Thank you very much,VGA-version to be working well on my dev-boards AEON.
But on the DE1 i can not make a version for the VGA,
for scan doubler-a apparently not enough internal memory :(
Info (170034): Selected device has 52 memory locations of type M4K. The current design requires 53 memory locations of type M4K to successfully fit.
Info (170033): Memory usage required for the design in the current device: 102% M4K memory block locations required
This is possible as it is correct ??
Thank you.

fbelavenuto
Mensajes: 100
Registrado: 08 Sep 2016, 13:10

Re: New MSX1 core

Mensaje por fbelavenuto » 21 Nov 2016, 11:35

Some bug!! The SAVE command should work!
desUBIKado escribió:Hola Fabio:

Muchas gracias por tu gran trabajo con este core. Me estoy divirtiendo mucho cargando ficheros .ROM, .CAS y .DSK.

Pero he intentado grabar un programa BASIC desde MSX-BASIC con el comando SAVE "A:HOLA.BAS" y el led rojo de que el ZX-UNO está usando la tarjeta SD parpadea, pero no termina de finalizar la grabación. Si hago RESET (CTRL+ALT+F12) y hago un DIR del directorio raíz veo esto:

Código: Seleccionar todo

HOLA     BAS                          0 15-02-17
 102337K in 28 files      0 bytes free
¿Se puede usar el comando SAVE con tu core?

fbelavenuto
Mensajes: 100
Registrado: 08 Sep 2016, 13:10

Re: New MSX1 core

Mensaje por fbelavenuto » 21 Nov 2016, 11:37

Yes, unfortunately there is no space on the DE-1 board! :(
azesmbog escribió:Hi, Fabio!
(sorry for my bad english)
Thank you very much,VGA-version to be working well on my dev-boards AEON.
But on the DE1 i can not make a version for the VGA,
for scan doubler-a apparently not enough internal memory :(
Info (170034): Selected device has 52 memory locations of type M4K. The current design requires 53 memory locations of type M4K to successfully fit.
Info (170033): Memory usage required for the design in the current device: 102% M4K memory block locations required
This is possible as it is correct ??
Thank you.

Avatar de Usuario
desUBIKado
Mensajes: 761
Registrado: 05 Ago 2016, 22:33

Re: New MSX1 core

Mensaje por desUBIKado » 21 Nov 2016, 21:01

Hola Fabio:

Una pregunta sobre MSX-DOS. ¿Es correcto que al poner MODE 41, MODE 42, ... MODE 80 devuelva el error *** Invalid parameter?

Si pongo un valor entre 1 y 40 funciona correctamente, y pone ese número de columnas por fila.

Responder