Nuevo core de PET por jepalza

Avatar de Usuario
jepalza
Mensajes: 323
Registrado: 02 Oct 2015, 18:52

Re: Nuevo core de PET por jepalza

Mensajepor jepalza » 03 Nov 2016, 07:00

Mejias3D escribió:Gracias jepalza. Nada se te resiste :okidoki;



Sí, controlar la vida a mis tres hijos :(

Jeje, bromas aparte, sí se me resisten: tengo una docena de cores arrancados, todos con algún problema difícil de solucionar, por ejemplo, el C64 (a quest también le está costando), el del Crazy Climber (no funciona el scroll vertical), el del MacPLus (falta implementar la SRAM com si fuera una DRAM de 16bits), el de la TurboGrafx que no arranca, pero quiere hacerlo, y ahora mismo, el del ZX81 que tiene una salida de vídeo penosa...

Pero poco a poco van cayendo. @quest también va puliendo algunos difíciles.

Avatar de Usuario
Radastan
Mensajes: 271
Registrado: 05 Oct 2015, 14:39

Re: Nuevo core de PET por jepalza

Mensajepor Radastan » 03 Nov 2016, 07:46

jepalza escribió:el del ZX81 que tiene una salida de vídeo penosa...


Es que si coges los esquemas originales la salida de vídeo era así, penosa, hay que modificar la salida de vídeo para que genere correctamente la misma:

http://trastero.speccy.org/cosas/JL/zx81(2)/ZX81-video.html

Si añades a la FPGA un circuito equivalente a uno de estos lo tienes solucionado.

Por cierto, el PET debería tener los pixels en verde claro, no en blanco.

Imagen

Avatar de Usuario
jepalza
Mensajes: 323
Registrado: 02 Oct 2015, 18:52

Re: Nuevo core de PET por jepalza

Mensajepor jepalza » 03 Nov 2016, 08:25

Radastan escribió:Es que si coges los esquemas originales la salida de vídeo era así, penosa, hay que modificar la salida de vídeo para que genere correctamente la misma

En ello ando. Funciona correctamente el ZX81 (se puede ver en el hilo viewtopic.php?f=21&t=656&start=10#p9984 ) pero se des-sincroniza mucho la VGA en cuanto usas el modo FAST del ZX81.


Radastan escribió:Por cierto, el PET debería tener los pixels en verde claro, no en blanco

Peor que eso, son amarillentos :oops: (en la foto no lo parece), pero para hacer pruebas me vale "asín", lo tengo en cuenta y los pongo verdes para cuando lo publique.

Avatar de Usuario
Radastan
Mensajes: 271
Registrado: 05 Oct 2015, 14:39

Re: Nuevo core de PET por jepalza

Mensajepor Radastan » 03 Nov 2016, 13:57

jepalza escribió:
Radastan escribió:Por cierto, el PET debería tener los pixels en verde claro, no en blanco

Peor que eso, son amarillentos :oops: (en la foto no lo parece), pero para hacer pruebas me vale "asín", lo tengo en cuenta y los pongo verdes para cuando lo publique.


Hombre, yo tuve uno y te puedo asegurar que era en verde, como en la foto.
El ordenador si estaba amarillento, pero un baño de KH7 y blanco como la leche.

Avatar de Usuario
desUBIKado
Mensajes: 223
Registrado: 05 Ago 2016, 22:33

Re: Nuevo core de PET por jepalza

Mensajepor desUBIKado » 03 Nov 2016, 14:16

¿Y no sería que podías elegir entre fósforo verde y fósforo ambar?

Avatar de Usuario
jepalza
Mensajes: 323
Registrado: 02 Oct 2015, 18:52

Re: Nuevo core de PET por jepalza

Mensajepor jepalza » 03 Nov 2016, 15:25

Según he podido leer en la wiki, solo se sacaron en verde.
Como yo no lo sabía, he empezado poniendo un blanco tirando a amarillo sucio... :lol: pero se cambia en un volao.

Avatar de Usuario
jepalza
Mensajes: 323
Registrado: 02 Oct 2015, 18:52

Re: Nuevo core de PET por jepalza

Mensajepor jepalza » 04 Nov 2016, 20:20

Dejo adjunto el core del Pet2001 para que juguéis con él. Por cierto, solo por VGA por ahora. El módulo no tiene salida de vídeo compuesto.

Y pido "sopitas" , dado que no consigo un WAV que sea capaz de cargar para probar.

La historia es que, para las pruebas de carga por cinta, no me quise volver loco bajando aplicaciones que pasasen de .TAP a .WAV, así que, encontré la página de un señor (http://petsynth.org/downloads_source/) donde se puede bajar un fichero en formato FLAC de un programa de sintetizador musical para el PET2001, y este, carga perfectamente (en mi caso, volumen al 75%). Probé a convertirlo a formato .WAV con un programa que bajé de la red (no recuerdo su nombre, lo borré despues) y este WAV también carga de maravilla. (os lo puedo pasar si queréis, pero es igual al FLAC)

Ahora, quiero probar a cargar otras cosas, pero veo un lío tremendo de formatos de cintas (.TAP, .PET, .P, .PRG o incluso .D64 (estos son de disco)) y trato de convertirlos a WAV con varios conversores que he bajado de la red, supuestamente para Commodore (no para PET, pero si, en teoría, compatibles con VIC20) y ninguno he logrado que cargue bien. Lo mas que he conseguido, es ver el nombre de lo que carga, pero acaba dando error.

Es mas, de las 10 conversiones a WAV que he realizado con los programas, hay tres versiones de WAV diferentes internamente, e incluso suenan diferente.

A ver si alguno logra dar con el formato correcto y el método ideal para pasar de cintas a sonidos del PET y poder cargar mas cosas.

El core lleva teclado con distribución "no" española, pero no es difícil de manejar. La tecla F1 cancela las cargas, la tecla ALT escribe en modo gráfico.
Adjuntos
pet2001.rar
Core del Commodore PET2001
(57.49 KiB) Descargado 78 veces


Volver a “PET”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado