Página 1 de 1

Struggling with Next Core

Publicado: 22 Sep 2017, 09:08
por namco
I've recently bought the ZX Uno as an interim board for the Next (for Dev purposes) and for some reason I can't get the Next to boot. When it goes through the boot procedure it just hangs here:

Imagen

Here are the contents of the SD Card:

Imagen

Re: Struggling with Next Core

Publicado: 22 Sep 2017, 11:47
por ManuFerHi
Possibly, does not correspond the core version with the SD files. I do not know what version of ZX-UNO you have, but this core and sd files are worth it.
https://github.com/ManuFerHi/ZXUNO_VGA_ ... res/TBBlue

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 12:39
por namco
Sorry, forgot to mention that mine was the 2M board!

Anyway, I only moved the files over and it does boot straight into the Next! :)

Is there any updates so I can get my sprite routine running? Or do I just need to update the core?

Thanks.

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 12:46
por ManuFerHi
namco escribió:Sorry, forgot to mention that mine was the 2M board!

Anyway, I only moved the files over and it does boot straight into the Next! :)

Is there any updates so I can get my sprite routine running? Or do I just need to update the core?

Thanks.


If you have the VGA 2M board you have the last version of TBBlue core, there have been no updates in this core for some time.

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 14:53
por namco
That's a little disappointing.

Hopefully there will be updates when the Next is officially released (to take in account the new sprite routines and layer scrolling etc)?

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 15:04
por ManuFerHi
namco escribió:That's a little disappointing.

Hopefully there will be updates when the Next is officially released (to take in account the new sprite routines and layer scrolling etc)?


The NEXT new sprite routines and layer scrolling is for now, exclusive to the NEXT, in the future it will be seen if they can be implemented in ZX-UNO. :cry:

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 15:14
por namco
Fair enough, I'll just use the beta versions of Zesarux for development for now. The Uno can be used for show-off purposes (instead of bringing the bulky Next unit or a Spectrum unit - I've done coding for the old)!

:)

Re: Struggling with Next Core

Publicado: 23 Sep 2017, 23:24
por Uto
As the Next is using a larger FPGA than ZX-Uno, and Next team says the Next FPGA is almost full, there is not likely the final Next core fits in the ZX-Uno FPGA. That doesn't mean though that a possible "Next lite" version can't fit. With "Next Lite" I mean a Next core version incluiding layer2 and sprites, but not including some other features. As the feature list of the Next has not been made official yet, we'll have to wait what's in and what can be pulled out to make that "lite" version. It would be even possible to make different lite versions, each one with different features, I doubt any game uses them all.

Of course, for that to be possible, first the Next team has to publish the core sources (and they said they will) and someone who knows how to do it has to trim those features.