Soporte para Flash W25Q128

Avatar de Usuario
Higgy
Mensajes: 56
Registrado: 30 Dic 2016, 23:57
Ubicación: Oxfordshire, England
Contactar:

Re: Soporte para Flash W25Q128

Mensajepor Higgy » 09 Mar 2017, 09:31

Hello,

The W24Q128 is a good development :okidoki;

Is this the correct procedure if a new blank Q128 is installed and I have a Raspberry Pi for unbricking?

1. Desolder Q32
2. Solder new Q128
3. Copy recovery.bit (from download attachment 1st post http://www.zxuno.com/forum/viewtopic.php?f=37&t=774) to Raspberry Pi /boot
4. Copy 16mb FLASH.ZX1 from a few posts down - http://www.zxuno.com/forum/download/file.php?id=1095 to blank ZX-UNO SDCard (FAT/FAT32?)
5. Follow 'Unbricking the ZX-Uno with Raspberry Pi' guide from User Manual:
* run various Raspberry Pi commands for jtag then,
* connect ZX-Uno to Raspberry Pi GPIO
* turn on ZX-Uno (with SDcard featuring FLASH.ZX1 (16mb file)
* type - pld load /boot/recovery.bit once Raspberry Pi has finished you flash the FLASH.ZX1 with ZX-Uno menu
6. Turn off Raspberry Pi and ZX-Uno.
7. Turn on ZX-Uno and enjoy lots and lots of Core slots :maestro:

Thanks

Avatar de Usuario
antoniovillena
Mensajes: 2504
Registrado: 27 Sep 2015, 20:41

Re: Soporte para Flash W25Q128

Mensajepor antoniovillena » 09 Mar 2017, 09:46

Yes. This is the correct procedure
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
Higgy
Mensajes: 56
Registrado: 30 Dic 2016, 23:57
Ubicación: Oxfordshire, England
Contactar:

Re: Soporte para Flash W25Q128

Mensajepor Higgy » 09 Mar 2017, 09:51

:gracias!:

Avatar de Usuario
Higgy
Mensajes: 56
Registrado: 30 Dic 2016, 23:57
Ubicación: Oxfordshire, England
Contactar:

Re: Soporte para Flash W25Q128

Mensajepor Higgy » 24 Mar 2017, 21:21

Hello,

I fitted my new Q128 chip and used my Raspberry Pi 3 to JTAG.
I used the recovery.bit and had my ZX-Uno connected to a screen. The BIOS screen appeared, but the are some red and black blocks on the screen. The red ones are flashing.
The text was a little mucked up and it was difficult to select things. I think I selected 'Update from SD card' but the border has gone gray and there are some moving horizontal lines (a bit like Spectrum loading bars) but it has been doing this for over 5mins. I guess the update from SDcard should be quicker?

Do you know what might have gone wrong? i am using the files I linked to a couple of posts previously. I will try and grab a screenshot (probably tomorrow now).

Thanks

Avatar de Usuario
antoniovillena
Mensajes: 2504
Registrado: 27 Sep 2015, 20:41

Re: Soporte para Flash W25Q128

Mensajepor antoniovillena » 24 Mar 2017, 22:35

Yes. This is a bug. Press cursor down 6 times and then cursor up 6 times and you will see the list correctly.

Higgy escribió:Hello,

I fitted my new Q128 chip and used my Raspberry Pi 3 to JTAG.
I used the recovery.bit and had my ZX-Uno connected to a screen. The BIOS screen appeared, but the are some red and black blocks on the screen. The red ones are flashing.
The text was a little mucked up and it was difficult to select things. I think I selected 'Update from SD card' but the border has gone gray and there are some moving horizontal lines (a bit like Spectrum loading bars) but it has been doing this for over 5mins. I guess the update from SDcard should be quicker?

Do you know what might have gone wrong? i am using the files I linked to a couple of posts previously. I will try and grab a screenshot (probably tomorrow now).

Thanks
http://antoniovillena.es
http://retrolandia.net
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
Higgy
Mensajes: 56
Registrado: 30 Dic 2016, 23:57
Ubicación: Oxfordshire, England
Contactar:

Re: Soporte para Flash W25Q128

Mensajepor Higgy » 24 Mar 2017, 23:54

Thanks.
Once I selected 'Update from SDcard' and pressed Cursor Left the screen/test went normal.
All flashed and now I have a nice long Core list :)

Avatar de Usuario
brunosilva
Mensajes: 277
Registrado: 18 Jun 2016, 19:54

Re: Soporte para Flash W25Q128

Mensajepor brunosilva » 16 May 2017, 01:57

@antonio

what's wrong with this procedure:

- copy the BACK16M to BIN folder
- start with rooted zx spectrum 48
- run the .BACK16M command to backup my flash and copy to another zxuno
- the commando says "Backup complete / 0 OK, 0:1"
- file FLASH.ZX1 in sd card is 0 bytes :(

firmware 0.61
Spectrum Core EXP25

ManuFerHi
Mensajes: 712
Registrado: 15 Nov 2015, 17:50

Re: Soporte para Flash W25Q128

Mensajepor ManuFerHi » 16 May 2017, 07:10

brunosilva escribió:@antonio

what's wrong with this procedure:

- copy the BACK16M to BIN folder
- start with rooted zx spectrum 48
- run the .BACK16M command to backup my flash and copy to another zxuno
- the commando says "Backup complete / 0 OK, 0:1"
- file FLASH.ZX1 in sd card is 0 bytes :(

firmware 0.61
Spectrum Core EXP25


After backup (lot of time :cry: ) write .LS


Volver a “Firmware”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados