ZX-UNO muerto tras actualizacion de CORE

Discursiones en general sobre el proyecto que no tienen cabida en otro foro / General discussion for uncateorized topics about the ZX-Uno project
Avatar de Usuario
kowols
Mensajes: 14
Registrado: 29 Mar 2016, 09:16

ZX-UNO muerto tras actualizacion de CORE

Mensaje por kowols » 17 Feb 2020, 23:09

Buenas, creo que he matado a mi ZX-UNO :(. Intente añadir el CORE arcade Phonenix haciendo un update desde la bios en el slot de memoria 10 y tras reiniciar ya no volvio a mostrar imagen en pantalla. He intentado grabar en la SD los archivos iniciales de los zip ESXDOS_ZX1.zip y ROMS_ZX1.zip, pero no ha funcionado. ¿Alguna idea?
Muchas gracias.

Avatar de Usuario
mcleod_ideafix
Mensajes: 821
Registrado: 27 Sep 2015, 00:14
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por mcleod_ideafix » 26 Feb 2020, 11:18

En principio, poner un core que no sea el de Spectrum, en un slot que no sea el de Spectrum, no debe producir esos fallos.¿Lo estás usando en modo RGB/video compuesto, o en modo VGA?
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
kowols
Mensajes: 14
Registrado: 29 Mar 2016, 09:16

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por kowols » 26 Feb 2020, 11:45

Hola mcleod, el slot 10 ya tenia un core de spectrum 128k grabado pero supuse que no era el principal que se graba en el slot 1. Lo uso con el cable RGB-SCART de Antonio Villena y tambien con el cable RCA. Por ninguna de las dos salidas de video se ha vuelto a ver la imagen. Le tengo encargado a Antonio el cable que conecta el USB Blaster al zx-uno para ver si lo puedo revivir con ese metodo. Se agradecen los consejos ; ).

Avatar de Usuario
mcleod_ideafix
Mensajes: 821
Registrado: 27 Sep 2015, 00:14
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por mcleod_ideafix » 26 Feb 2020, 12:19

Primera cosa que puedes hacer: con el equipo encendido, pulsa BloqDespz para cambiar de modo VGA a modo RGB, a ver si es eso lo que se ha desconfigurado y por eso no ves nada.
Si al hacer eso ves imagen, entonces haz un reset maestro y nada más hacerlo (dejarás de ver imagen de nuevo), pulsa como un loco F2 para entrar en BIOS. Aunque no veas nada, habrás entrado en BIOS. Pulsa BloqDespl para volver a tener imagen y comprueba que la selección de modo de video en BIOS sea la correcta.
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
kowols
Mensajes: 14
Registrado: 29 Mar 2016, 09:16

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por kowols » 26 Feb 2020, 12:27

Perfecto mcleod asi lo hare. Estoy deseando llegar a casa para probar lo que me has dicho ; ). Ya te cuento el resultado.
Gracias MIL!!!

Avatar de Usuario
kowols
Mensajes: 14
Registrado: 29 Mar 2016, 09:16

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por kowols » 26 Feb 2020, 17:07

Nada, BloqDespl no me permite mostrar imagen en ninguno de los dos modos. Esperare al cable para conectar el zx-uno con el usb blaster.
Gracias de todas formas.

Avatar de Usuario
mcleod_ideafix
Mensajes: 821
Registrado: 27 Sep 2015, 00:14
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por mcleod_ideafix » 26 Feb 2020, 17:39

Cuando enciende el ZXUNO, ¿se observa actividad en el LED que está más cerca del borde de la placa? (el otro se queda siempre encendido)
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
desUBIKado
Mensajes: 828
Registrado: 05 Ago 2016, 22:33

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por desUBIKado » 26 Feb 2020, 18:54

Intenta también conectar un joystick y cuando arranque tras un hard reset pulsar dirección abajo en el joystick. Si no se ve imagen pulsa entonces BloqDespz para cambiar de modo VGA a modo RGB. Si hay suerte veras una pantalla azul con la lista de cores y una opción al final que pone "Enter Setup" para entrar en la BIOS.

Avatar de Usuario
kowols
Mensajes: 14
Registrado: 29 Mar 2016, 09:16

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por kowols » 26 Feb 2020, 19:21

Al encender se quedan los 2 led con la luz fija sin actividad, uno en rojo (el cercano al borde de la placa) y el otro en verde. Despues se mantienen igual.

Ahora mismo de joysticks solo tengo a mano un Joypad Panasonic de MSX. Lo he probado haciendo lo que me comentas, desUBIKado, y no hace nada, sigue la pantalla en negro. Me hare con un joystick db9 normal para probar a ver.

Avatar de Usuario
desUBIKado
Mensajes: 828
Registrado: 05 Ago 2016, 22:33

Re: ZX-UNO muerto tras actualizacion de CORE

Mensaje por desUBIKado » 26 Feb 2020, 19:34

kowols escribió:
26 Feb 2020, 19:21
Al encender se quedan los 2 led con la luz fija sin actividad, uno en rojo (el cercano al borde de la placa) y el otro en verde. Despues se mantienen igual.

Ahora mismo de joysticks solo tengo a mano un Joypad Panasonic de MSX. Lo he probado haciendo lo que me comentas, desUBIKado, y no hace nada, sigue la pantalla en negro. Me hare con un joystick db9 normal para probar a ver.
Prueba con la flecha abajo de los cursores del teclado PS/2. Debería tener el mismo efecto que con el joystick

Responder