Montando el prototipo V4

Dudas, cuestiones, sugerencias y peticiones en general sobre el proyecto / Questions and requests about the project
Avatar de Usuario
antoniovillena
Mensajes: 2597
Registrado: 27 Sep 2015, 20:41

Re: Montando el prototipo V4

Mensaje por antoniovillena » 07 Mar 2016, 21:41

Ahí van. El VGA va sin resistencias. El RGB (Scart) tiene una resistencia (a ser posible de 75 ohm, pero acepta un rango amplio) que va al pin 16 del Scart.
Adjuntos
cableVGA.jpg
cableScart.jpg

Avatar de Usuario
DistWave
Mensajes: 180
Registrado: 14 Oct 2015, 19:24
Ubicación: Zaragoza

Re: Montando el prototipo V4

Mensaje por DistWave » 07 Mar 2016, 23:52

En mi prototipo v4, GND está en el pin 1 de la foto y mirando el esquema, los pines van etiquetados en orden inverso...

1 GND
2 VSYNC
3 HSYNC
4 3.3v
5 B
6 G
7 R
8 Audio Right
9 Audio Left

¿Cual es el correcto?

Avatar de Usuario
Quest
Mensajes: 900
Registrado: 27 Sep 2015, 00:20

Re: Montando el prototipo V4

Mensaje por Quest » 08 Mar 2016, 00:11

Efectivamente es como dice Distwave.

Antonio, has indicado los pines al reves en las fotos. Ademas en las 4.1 añadi la serigrafia del pin 1 precisamente para evitar confusiones.
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
antoniovillena
Mensajes: 2597
Registrado: 27 Sep 2015, 20:41

Re: Montando el prototipo V4

Mensaje por antoniovillena » 08 Mar 2016, 00:51

Pues mañana lo corrijo. Gracias distwave. Tomé como referencia la hoja de conectores, así que también habrá que corregir dicha hoja.

Repasando también está invertido el pinout del JTAG (recordar los de la 4.0 que vuestro JTAG es distinto). Y la serigrafía del pin 1 del puerto RGB también está mal. Lo que voy a hacer es mantener numeración de izquierda a derecha y cambiar el orden de las señales

http://zxuno.speccy.org/ficheros/Pinout ... CB_v41.pdf

Avatar de Usuario
antoniovillena
Mensajes: 2597
Registrado: 27 Sep 2015, 20:41

Re: Montando el prototipo V4

Mensaje por antoniovillena » 08 Mar 2016, 01:12

Arreglado

Avatar de Usuario
Quest
Mensajes: 900
Registrado: 27 Sep 2015, 00:20

Re: Montando el prototipo V4

Mensaje por Quest » 08 Mar 2016, 08:59

Antonio,

Lo siento, pero no. Tanto el .brd como el .sch de Eagle estaban perfectamente, y las serigrafías del pin 1 estaban bien las dos, tanto la de RGB como la de JTAG. Y el JTAG no está invertido. ¿Invertido con respecto a qué? Estaba bien. Es como yo lo tengo conectado, ya que me hice ambos cables , y coincide perfectamente. Lo que está mal es la hoja PDF de conectores. Es lo único que está mal.
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Avatar de Usuario
chukyegg
Mensajes: 39
Registrado: 24 Feb 2016, 14:04

Re: Montando el prototipo V4

Mensaje por chukyegg » 08 Mar 2016, 09:30

Me estais haciendo un lio.......

Aver.

¿LAs fotos que hay ahora mismo es el esquema bueno?

Avatar de Usuario
Haplo
Mensajes: 366
Registrado: 05 Oct 2015, 13:51
Ubicación: Ciudad Real

Re: Montando el prototipo V4

Mensaje por Haplo » 08 Mar 2016, 09:42

Tranqulidad, lo están corrigiendo.

Avatar de Usuario
antoniovillena
Mensajes: 2597
Registrado: 27 Sep 2015, 20:41

Re: Montando el prototipo V4

Mensaje por antoniovillena » 08 Mar 2016, 10:03

chukyegg escribió:Me estais haciendo un lio.......

Aver.

¿LAs fotos que hay ahora mismo es el esquema bueno?
Las fotos si. Lo que está mal es el cambio que hice yo en el repositorio (no era necesario hacerlo), y esta hoja de conectores

http://zxuno.speccy.org/ficheros/Pinout ... CB_v41.pdf

Eso es lo que estamos rectificando. Pero las fotos están bien

Avatar de Usuario
Quest
Mensajes: 900
Registrado: 27 Sep 2015, 00:20

Re: Montando el prototipo V4

Mensaje por Quest » 08 Mar 2016, 10:04

Las fotos del post de Antonio ya estan corregidas y puedes usarlas como referencia sin problema :)
estamos en proceso de corregir el PDF del pineado, pero como digo puedes usar las fotos sin problema.

Si conectais el VGA y no veis nada al arrancar, es normal. Aun no se puede elegir VGA con teclas ni en Bios (esta por desarrollar) en el core principal de Spectrum. De momento el unico modo de activar VGA en spectrum es tener la ultima versión de ZXUNOCFG metida en la carpeta BIN de la SD (con el ultimo exdos disponible) y una vez que haya arrancado el spectrum teclear a ciegas:

.ZXUNOCFG -v1

Para otros cores que arrancan en VGA, como el de Nes, Apple II o el de Acorn Atom, no hay problema (cargando desde jtag o teniendolos como cores de arranque, lo cual se puede hacer en Bios desde la ultima version)
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA

Responder