Nuevo usuario de ZXUNO, del foro y primera pregunta

Dudas, cuestiones, sugerencias y peticiones en general sobre el proyecto / Questions and requests about the project
Avatar de Usuario
MarleyFynn
Mensajes: 3
Registrado: 11 Abr 2017, 12:42

Nuevo usuario de ZXUNO, del foro y primera pregunta

Mensajepor MarleyFynn » 20 Abr 2017, 22:00

Hola! Mi nombre es Felipe. Soy de Zaragoza. Aunque he seguido el proyecto y el foro desde el principio por fin me he hecho hace una semana con un ZXUNO y a pesar de los comentarios que he leido aquí y leer las instrucciones tengo un problemilla que no termino de solucionar. He leido en otro hilo sobre las diferencias entre la BIOS v0.59 y los cores que debía llevar el UNO anteriormente. He leido que cargando por defecto la ROM zx spectrum 48k que lleva instalada mi flash no puede arrancar programas o juegos de 128k porque obviamente no es el core adecuado. En mi lista de roms me aparecen en éste orden: Slot 0: ZX Spectrum 48k, Slot 1: ZX +2a 4.1, Slot 5: SE Basic IV 4.0 Anya, Slot 7: ZX Spetrum 48k carga, Slot 8: Rooted ZX Spectrum 4, Slot 9: Inves Spectrum+, Slot 10: ZX Spectrum +2, Slot 12: Pentagon 128, y Slot 14: ZX +3e DivMMC 1.4
Entiendo que no necesito actualizar de momento los cores, roms etc porque al ser reciente ya está instalado todo lo último (de hecho en la sección descargas de esta web explica como instalar flash actualizada y hay un archivo para hacerlo pero creo que será una versión anterior a lo que tengo instalado actualmente) pero para poder acceder y usar juegos de 128k y poderlos cargar desde la tarjeta sd con el comando NMI Ctrl+Alt+f5 que Rom debo usar y como? Lo pregunto porque he probado arrancando como core activa con los Slots 1, 7, 8, 9, 10, 12 y 14 y el comando NMI SOLO SE ACTIVA con la rom Rooted y los programas de 128k funcionan perfectamente. Claro he leido que no se use esta rom porque podemos dañar el zxuno así que realmente no se que puedo hacer. También en el menú Main de la bios tenia las opciones todas en auto y no funcionaban y activé NMI-divMMC Enabled pero tampoco tiene efecto, de hecho al hacer el comando NMI se oye un zumbido. Habían unos consejos de usar unos pokes pero he probado a activarlos desde el esxdos pero no tienen efecto. Agradecería una ayudita con el tema.
Por lo demás super entusiasmado con el ZXUNO. He probado la rom de Amstrad CPC y he cargado por EAR varios juegos perfectamente desde un cassete portatil y me parece espectacular. Solo falta un día alcanzar a que pueda lanzar una ROM de CPC6128 y será el sueño hecho realidad para mi y supongo que para mucha más gente.
Un saludo y muchas gracias :gracias!:
PD: Saludos Samuel @SamQuest ! Soy el que va todos los años con mi crío a daros palique para la RetroMañia xD ;)

Avatar de Usuario
Quest
Mensajes: 839
Registrado: 27 Sep 2015, 00:20

Re: Nuevo usuario de ZXUNO, del foro y primera pregunta

Mensajepor Quest » 21 Abr 2017, 01:05

Hombre Felipe :D Dichosos los ojos...

Mira que hablamos veces todos los años y no te terminabas de decidir a pillarlo... Y mira que intentaba convencer.. ;)

Bueno, respecto a lo que te pasa, será una tontería. Hace poco a un usuario le pasaba algo parecido aquí: viewtopic.php?f=12&t=517

Revísalo.

De todos modos, también puedes pasarte por http://zxuno.speccy.org/instrucciones.shtml
y echar un ojo a la parte de las descargas para la SD y la actualización de las ROMs. Es el pack que pusimos para actualizar los ZX-UNOs del crowdfunding pero también vale para el tuyo. Ya verás como las instrucciones son fáciles. Como no hay que tocar los cores para hacerlo (sólo actualiza las ROMs), no tendrás problema. El resto de cosas no se verá afectado. Esas roms del pack ya están preparadas para funcionar correctamente con NMI de ESXDos. Sólo tienes que asegurarte de qué versión de los archivos de ESXDos tienes instalada. Para asegurarte la compatibilidad, usa los archivos del enlace.

También estaría bien saber qué versión de la ROM de ESXDos tienes en tu ZX-UNO (eso te pasaría por no pillar uno ya bien preparadito cuando te dije ;) ;)) y ver si puede estar causando incompatibilidades. En cualquier caso leete el hilo del compañero y también la página, ah y el FAQ en http://www.ngpaws.com/zxunofaq.html#2020 que también te puede ayudar.

Para cualquier cosa, ya sabes :)

Saludos!
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA
Imagen

Avatar de Usuario
MarleyFynn
Mensajes: 3
Registrado: 11 Abr 2017, 12:42

Re: Nuevo usuario de ZXUNO, del foro y primera pregunta

Mensajepor MarleyFynn » 21 Abr 2017, 07:20

Muchas gracias Samuel. Hago unas pruebas y os digo. Saludos!!

Avatar de Usuario
MarleyFynn
Mensajes: 3
Registrado: 11 Abr 2017, 12:42

Re: Nuevo usuario de ZXUNO, del foro y primera pregunta

Mensajepor MarleyFynn » 22 Abr 2017, 16:48

Funcionando!!! Muchas gracias Samuel! He seguido los pasos tal como explica en el F.Q.A. copiando a la SD las carpetas del ESXDOS y el archivo ROMS.ZX1 de vuestra sección Descargas. He arrancado con la rom "root" y ejecutado .ROMSUPGR escrito así en mayusculas pues con minusculas no lo aceptaba y voilá! reinicio y funciona todo perfectamente. Por fin puedo acceder a SD desde una rom de 128k. Las demás caracteristicas de la Bios las he dejado como están en Automatico. Voy a ir testeando todo lo que pille con cassetes y cargas desde EAR y os voy diciendo resultados poco a poco. Si con la Rom de Amstrad veo algún detalle a destacar cargando programas os lo digo y de paso me echo unas viciaditas xD Un saludo!

Avatar de Usuario
Quest
Mensajes: 839
Registrado: 27 Sep 2015, 00:20

Re: Nuevo usuario de ZXUNO, del foro y primera pregunta

Mensajepor Quest » 22 Abr 2017, 19:24

Genial, Felipe, me alegro mucho :)

Ya nos irás contando tus pruebecillas.


Salud!
http://www.zxuno.com
ZX-Uno · Clon de ordenador ZX Spectrum basado en FPGA
Imagen


Volver a “Preguntas y peticiones / Questions and requests”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados